10.6 Server - Dovecot Issues

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

10.6 Server - Dovecot Issues

idbaker
Intermittently, dovecot seems to be bouncing messages inbound for some of my users.

Here is the mail.log entry for a successful delivery:

Aug 21 16:58:45 mail postfix/pipe[64094]: D68783AE0F75: to=<[hidden email]>, relay=dovecot, delay=0.08, delays=0/0.01/0/0.07, dsn=2.0.0, status=sent (delivered via dovecot service)

And here is what a bounce looks like

Aug 22 07:29:28 mail postfix/local[93916]: error: od[getpwnam_ext]: No record for user sblondin
Aug 22 07:29:28 mail postfix/pipe[93944]: 852C43AE7ACC: to=<[hidden email]>, relay=dovecot, delay=15, delays=0.14/0.05/0/15, dsn=5.1.1, status=bounced (user unknown)

And a bit later another succcessful delivery.

Aug 22 07:56:37 mail postfix/pipe[95021]: 14AF73AE82F0: to=<[hidden email]>, relay=dovecot, delay=0.5, delays=0.08/0.02/0/0.4, dsn=2.0.0, status=sent (delivered via dovecot service)

No changes to this user's account were made during this time period.  I'm flummoxed.

Anythoughts as to what might be going on here, and/or how to debug this further?

Thanks in advance...

Ian

 _______________________________________________
Do not post admin requests to the list. They will be ignored.
Macos-x-server mailing list      ([hidden email])
Help/Unsubscribe/Update your Subscription:
https://lists.apple.com/mailman/options/macos-x-server/lists%2Bs10970n2h62%40n7.nabble.com

This email sent to [hidden email]
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: 10.6 Server - Dovecot Issues

The Mac OS X Server Mailing List mailing list

Am 24 Aug 2014 um 00:49 schrieb Ian Baker <[hidden email]>:

> Intermittently, dovecot seems to be bouncing messages inbound for some of my users.
>
> Here is the mail.log entry for a successful delivery:
>
> Aug 21 16:58:45 mail postfix/pipe[64094]: D68783AE0F75: to=<[hidden email]>, relay=dovecot, delay=0.08, delays=0/0.01/0/0.07, dsn=2.0.0, status=sent (delivered via dovecot service)
>
> And here is what a bounce looks like
>
> Aug 22 07:29:28 mail postfix/local[93916]: error: od[getpwnam_ext]: No record for user sblondin
> Aug 22 07:29:28 mail postfix/pipe[93944]: 852C43AE7ACC: to=<[hidden email]>, relay=dovecot, delay=15, delays=0.14/0.05/0/15, dsn=5.1.1, status=bounced (user unknown)
>
> And a bit later another succcessful delivery.
>
> Aug 22 07:56:37 mail postfix/pipe[95021]: 14AF73AE82F0: to=<[hidden email]>, relay=dovecot, delay=0.5, delays=0.08/0.02/0/0.4, dsn=2.0.0, status=sent (delivered via dovecot service)
>
> No changes to this user's account were made during this time period.  I'm flummoxed.
>
> Anythoughts as to what might be going on here, and/or how to debug this further?
>

any hints in the od or mail access logs?
maybe you need to rebuild your OD database from backup.
cheers
Matthias




 _______________________________________________
Do not post admin requests to the list. They will be ignored.
Macos-x-server mailing list      ([hidden email])
Help/Unsubscribe/Update your Subscription:
https://lists.apple.com/mailman/options/macos-x-server/lists%2Bs10970n2h62%40n7.nabble.com

This email sent to [hidden email]
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: 10.6 Server - Dovecot Issues

The Mac OS X Server Mailing List mailing list
In reply to this post by idbaker
On 2014-09-28, at 6:23 AM, Matthias Schmidt wrote:

>
> Am 24 Aug 2014 um 00:49 schrieb Ian Baker <[hidden email]>:
>
>> Intermittently, dovecot seems to be bouncing messages inbound for some of my users.
>>
>> Here is the mail.log entry for a successful delivery:
>>
>> Aug 21 16:58:45 mail postfix/pipe[64094]: D68783AE0F75: to=<[hidden email]>, relay=dovecot, delay=0.08, delays=0/0.01/0/0.07, dsn=2.0.0, status=sent (delivered via dovecot service)
>>
>> And here is what a bounce looks like
>>
>> Aug 22 07:29:28 mail postfix/local[93916]: error: od[getpwnam_ext]: No record for user sblondin
>> Aug 22 07:29:28 mail postfix/pipe[93944]: 852C43AE7ACC: to=<[hidden email]>, relay=dovecot, delay=15, delays=0.14/0.05/0/15, dsn=5.1.1, status=bounced (user unknown)
>>
>> And a bit later another succcessful delivery.
>>
>> Aug 22 07:56:37 mail postfix/pipe[95021]: 14AF73AE82F0: to=<[hidden email]>, relay=dovecot, delay=0.5, delays=0.08/0.02/0/0.4, dsn=2.0.0, status=sent (delivered via dovecot service)
>>
>> No changes to this user's account were made during this time period.  I'm flummoxed.
>>
>> Anythoughts as to what might be going on here, and/or how to debug this further?
>>
>
> any hints in the od or mail access logs?
> maybe you need to rebuild your OD database from backup.
> cheers
> Matthias

Turns out it was related to Time Machine.  Looks like while Time Machine was running it was blocking access to OD for validation of existing users.  I've stopped running Time Machine, and the problem has gone away.

Ian

 _______________________________________________
Do not post admin requests to the list. They will be ignored.
Macos-x-server mailing list      ([hidden email])
Help/Unsubscribe/Update your Subscription:
https://lists.apple.com/mailman/options/macos-x-server/lists%2Bs10970n2h62%40n7.nabble.com

This email sent to [hidden email]
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: 10.6 Server - Dovecot Issues

The Mac OS X Server Mailing List mailing list

On 28 Sep 2014, at 13:47, OS X Server Mail List <[hidden email]> wrote:

>Turns out it was related to Time Machine.  Looks like while Time Machine was running it was blocking access to OD for validation of existing users.  I've stopped running Time Machine, and the problem has gone away.

Very good to know. Well done for diagnosing.

Angus

 _______________________________________________
Do not post admin requests to the list. They will be ignored.
Macos-x-server mailing list      ([hidden email])
Help/Unsubscribe/Update your Subscription:
https://lists.apple.com/mailman/options/macos-x-server/lists%2Bs10970n2h62%40n7.nabble.com

This email sent to [hidden email]
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: 10.6 Server - Dovecot Issues

The Mac OS X Server Mailing List mailing list

On 2014-09-28, at 8:56 AM, OS X Server Mail List wrote:

>
> On 28 Sep 2014, at 13:47, OS X Server Mail List <[hidden email]> wrote:
>
>> Turns out it was related to Time Machine.  Looks like while Time Machine was running it was blocking access to OD for validation of existing users.  I've stopped running Time Machine, and the problem has gone away.
>
> Very good to know. Well done for diagnosing.

Thanks but it wasn't me - I posted on the dovecote list and Jeroen Scheerder replied with the answer.

Gotta love mail lists that work!

Ian

 _______________________________________________
Do not post admin requests to the list. They will be ignored.
Macos-x-server mailing list      ([hidden email])
Help/Unsubscribe/Update your Subscription:
https://lists.apple.com/mailman/options/macos-x-server/lists%2Bs10970n2h62%40n7.nabble.com

This email sent to [hidden email]
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: 10.6 Server - Dovecot Issues

The Mac OS X Server Mailing List mailing list
In reply to this post by The Mac OS X Server Mailing List mailing list
Smart work.


Mike Matthews, Managing Director, Lineal Software Solutions Ltd

Apple Reseller, Microsoft Partner, SQLWorks Business Partner
phone: 01271 375999 | web: lineal.co.uk | email: [hidden email]




On 28 Sep 2014, at 13:47, OS X Server Mail List <[hidden email]> wrote:

> On 2014-09-28, at 6:23 AM, Matthias Schmidt wrote:
>
>>
>> Am 24 Aug 2014 um 00:49 schrieb Ian Baker <[hidden email]>:
>>
>>> Intermittently, dovecot seems to be bouncing messages inbound for some of my users.
>>>
>>> Here is the mail.log entry for a successful delivery:
>>>
>>> Aug 21 16:58:45 mail postfix/pipe[64094]: D68783AE0F75: to=<[hidden email]>, relay=dovecot, delay=0.08, delays=0/0.01/0/0.07, dsn=2.0.0, status=sent (delivered via dovecot service)
>>>
>>> And here is what a bounce looks like
>>>
>>> Aug 22 07:29:28 mail postfix/local[93916]: error: od[getpwnam_ext]: No record for user sblondin
>>> Aug 22 07:29:28 mail postfix/pipe[93944]: 852C43AE7ACC: to=<[hidden email]>, relay=dovecot, delay=15, delays=0.14/0.05/0/15, dsn=5.1.1, status=bounced (user unknown)
>>>
>>> And a bit later another succcessful delivery.
>>>
>>> Aug 22 07:56:37 mail postfix/pipe[95021]: 14AF73AE82F0: to=<[hidden email]>, relay=dovecot, delay=0.5, delays=0.08/0.02/0/0.4, dsn=2.0.0, status=sent (delivered via dovecot service)
>>>
>>> No changes to this user's account were made during this time period.  I'm flummoxed.
>>>
>>> Anythoughts as to what might be going on here, and/or how to debug this further?
>>>
>>
>> any hints in the od or mail access logs?
>> maybe you need to rebuild your OD database from backup.
>> cheers
>> Matthias
>
> Turns out it was related to Time Machine.  Looks like while Time Machine was running it was blocking access to OD for validation of existing users.  I've stopped running Time Machine, and the problem has gone away.
>
> Ian
>
> _______________________________________________
> Do not post admin requests to the list. They will be ignored.
> Macos-x-server mailing list      ([hidden email])
> Help/Unsubscribe/Update your Subscription:
> https://lists.apple.com/mailman/options/macos-x-server/mike.matthews%40lineal.co.uk
>
> This email sent to [hidden email]




 _______________________________________________
Do not post admin requests to the list. They will be ignored.
Macos-x-server mailing list      ([hidden email])
Help/Unsubscribe/Update your Subscription:
https://lists.apple.com/mailman/options/macos-x-server/lists%2Bs10970n2h62%40n7.nabble.com

This email sent to [hidden email]
Loading...